Troubleshooting Streamlit in Snowflake

The following scenarios can help you troubleshoot issues that can occur when working with Streamlit in Snowflake.

You cannot load the Streamlit app

Each Streamlit app running in Streamlit in Snowflake uses a unique subdomain.

Ensure that *.snowflake.app is on the allowlist in your network, including content filtering systems, and can connect to Snowflake. When this domain is on the allowlist, your apps can communicate with Snowflake servers without any restrictions.

In addition, to prevent any issues connecting to the Snowflake backend, ensure that WebSockets are not blocked in your network configuration.

Error

Could not reload streamlit files.
Error: 092806 (P0002): The specified Streamlit was not found.

Cause

The Snowflake WebSocket connection cannot reach the endpoint associated with the application.

Solution

Add *.snowflake.app to the allowlist on the organization’s firewall configuration.

You cannot see your data or change your database

You might not be able to see your data or change the database, warehouse, or role because Streamlit apps run with owner’s rights, which means that they run with the privileges of the owner, not the privileges of the caller. Streamlit apps use the database and schema that the Streamlit in Snowflake app was created in, not the database and schema that the caller is currently using.

For more information, see Understanding owner’s rights and Streamlit in Snowflake apps.

Streamlit library feature does not work

Ensure that you use the Streamlit library version and a feature that are supported by Streamlit in Snowflake. For more information, see Supported versions of the Streamlit library and Unsupported Streamlit features.

To ask questions on features in the open-source Streamlit library, see Streamlit Community Forum (https://discuss.streamlit.io/).

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